How it is working

Upgrades and PMR File Compatibility

Occasionally new versions of PhotoModeler will create PMR project files that cannot be read with older versions of PhotoModeler. i.e. PMRs are not always backward compatible.

Old versions of PhotoModeler PMR project files can always be read by new versions of the program. i.e. PMRs are always forward compatible.

The table below shows all version from 2017.0 on, and if there are any file compatibility issues.

The 'Compatibility Issue' column indicates if this version will write PMR files that are incompatible with previous versions. The possible values are:

  • none - means this version did not introduce any compatibility issues.
  • all - means that this version will write PMR files that are incompatible with previous versions in all cases.
  • 'object name' - means that if you have a project that includes this object type (e.g. a cylinder), this version will write PMR files that are incompatible with previous versions (otherwise it will be compatible).
Version Date Compatiblity Issue
2018.0.0 Dec. 14, 2017 none
2017.1.1 Sep. 25, 2017 all
2017.1.0 Aug. 22, 2017 Cylinders
2017.0.2 May 26, 2017 all
2017.0.1 May 4, 2017 none
2017.0.0 Apr. 10, 2017 none

Examples:

  • If you save a PMR file with 2017.1.1 it cannot be read by any previous version.
  • If you save a PMR with 2017.0.0 it can be read by 2017.0.1 up to present - always forward compatible.
  • If you save a file with 2017.1.0 that does not have cylinders it can be read by 2071.0.2 but not 2017.0.1 or earlier (because of the 'all' in 2017.0.2.

 

© 2017 Eos Systems Inc.