New Features and Enhancements In Older Versions

We are committed to the on-going support and improvement of our products. To show the history of that committment we list below the improvements we've made to older versions.

PhotoModeler 6 Scanner Changes
Please note that the following changes are specific to PhotoModeler Scanner but any particular version will also include all changes of the same version number of PhotoModeler as listed in the section below.

  • 6.4
    • Meshing component replacement. The Meshing component (Modify Mesh dialog and tools) has been replaced. Faster processing, no separate meshing license code, and the ability to move license online are some of the benefits.
    • ... see PhotoModeler 6.4 changes below.
  • 6.3.3
    • DSM Time Display. The DSM summary dialog now shows how long the PointMesh creation took.
    • ... and 1 other small fix.
  • 6.3.2
    • NetFloat licensing. Network floating licenses are now available with PhotoModeler Scanner.
    • PointMesh Project Merge. Project Merge can now merge PointMeshes from different projects into one project.
    • ... and 1 other small fix.
  • 6.3.1
    • No scanner specific changes - see PhotoModeler 6.3.1 list below.
  • 6.3.0
    • RGB export. RGB data is now optionally exported in the XYZ point cloud txt file format.
    • ... and 2 other fixes and small changes.
  • 6.2.4
    • Six fixes and small changes.
  • 6.2.3
    • Isolated Point Filter. A new step in the Modify Point Mesh dialog provides a noise and isolated-point filter. Other filtering improvements reduce other types of noise.
    • ... and 7 other fixes and small changes.
  • 6.2.2
    • Five fixes and small changes.
  • 6.2.1
    • Split Point Meshes. A new tool provides for spliting of point meshes into two. Any points or triangles selected in Point Mesh Edit Mode will be removed from their current meshes and added to a new one when this tool is selected.
    • Triangle Editing. Point Mesh Edit Mode now allows selection, center-around, and deletion of point mesh triangles.
    • Point Mesh Edit Undo. Added undo and re-do of point mesh edit deletes.
    • Improved Point Mesh Table. Added new columns to the Point Mesh Table for number of countors, sampling rate used (and units used), depth range, texture type, extents, and matching region Radius.
    • ... and 23 other fixes and small changes.

PhotoModeler 6 Changes
The following changes are included in both PhotoModeler and PhotoModeler Scanner.

  • 6.4
    • New DDE MergeProjects command. Ability to merge multiple projects into one via a DDE programming command.
    • ... and 4 other small fixes.
  • 6.3.3
    • Three fixes and small changes.
  • 6.3.2
    • Html Changes log. The Changes.txt file used to log all the changes and fixes made to the programs is now in html format for easier reading.
    • ... and 10 other fixes and small changes.
  • 6.3.1
    • New DDE Commands. AddLine, ShowPhoto and IdealizeProject.
    • ... and 25 other fixes and small changes.
  • 6.3.0
    • RAD Targets. 999 coded targets with a new design that makes them more robust in noisy images and faster to detect (with Coded Targets Module).
    • Improved Automation. New automarking algorithms, and new error point detection provides a very robust and efficient automated measurement system.
    • ... and 51 other fixes and small changes.
  • 6.2.4
    • Five fixes and small changes.
  • 6.2.3
    • New Measure Capabilities. New measurements displayed in Measure pane for selected items: closest distance between point and line features, closest distance point to a surface, closest distance between line features, and angle between two camera station view vectors.
    • ... and 50 other fixes and small changes.
  • 6.2.2
    • New licensing system with floating capability. A new licensing system has been implemented, providing more flexibility and new licensing options (eg network floating, license moving options etc). The change will generally be transparent to current users. See the Floating License page.
    • Reference Helper Lines. A new preference controls the number of reference helper lines displayed: all, 1 or none.
    • Hiding 3D Layers. The layer dialog has 2 new check boxes: 'Put selected
      objects into selected layer', and 'In all 3D views, hide the selected layer'. These tools provide a short cut for hiding objects in the 3D View window quickly.
    • ... and 52 other fixes and small changes.
  • 6.1.6
    • Improvements to MAXScript export. All surface types, cylinders, and imported lines can now be exported; camera exports include image planes; format size and image resolution are ouput as rendering sizes.
    • Surface Draw point status bar update. Status bar now shows associated surface ID.
    • Google 3D Warehouse Support. KMZ export has been reformatted to allow for uploading to new open-to-public Google 3D Warehouse.
    • DXF Import Improvement. DXF import now reads the 3D poly mesh data sub type of POLYLINE entities.
    • ... and 29 other fixes and small changes.
  • 6.1.5
    • User-configurable 3D navigation. Added the ability to zoom, pan, and rotate the 3d model by mouse-down-dragging anywhere in the 3D Viewer window.
    • New FBX export file format. Added FBX export of points, surfaces and camera positions.  
    • Camera stations with image planes. Added an option to display the camera station symbol with image planes in the 3D viewer.
    • Reconfigured surface draw and point ID visibility. The surface draw settings on the 3D viewer and export options have been split into points and lines. The option for IDs has also been updated to affect points, surface draw points and offsets.
    • ... and 43 other fixes and small changes.
  • 6.1.4
    • Mouse-over auto-activation: Added a new option to allow photo, table or 3D Viewer window activation when mouse cursor enters pane instead of requiring a click.  
    • ... and 7 other fixes and small changes.
  • 6.1.3
    • Camera station and geo-coded EXIF support in Google Earth export: Added options to use camera stations and/or use geo-coded EXIF data as coordinates in Google Earth export.
    • Auto-arrange photos during referencing: Added an option to automatically arrange source and destination photos while referencing.
    • Better control over texture rebuilds: Added options to control when ‘fast’ and ‘quality’ textures get rebuilt in the 3D Viewer after processing.
    • New pane controls: Added a menu to pane title bars for quick access to common pane controls like tile or maximize/tab etc.
    • ... and 58 other fixes and small changes.
  • 6.1.2
    • 3D Studio MaxScript: Added support for 3D Studio MaxScript export. Camera positions, point, line and curve data are exported.
    • Unlimited 3D Viewer Texture: The 3D viewer texture image size can now be increased beyond the graphics card's texture size limit and is now
      only limited by the amount of RAM.
    • KMZ Curves: Added the ability to export curve data to Google Earth
      KMZ files.
    • ... and 23 other fixes and small changes.
  • 6.1.1
    • small fix: Resolved an issue with shapes, that were created using version 6.1, not working correctly.
  • 6.1
    • Offset Points: Added a new offset point feature that has two main uses. To create a new point for an EM or jig of known dimension and to allow a point that can't be targeted to be solved accurately using two other targets. See the help file for additional detail. Also see the Using Offset Points for Forensic Height Measurement KB article for an interesting application.
    • Photography Guidelines: The Help file now includes a section on Photography Guidelines to match the User Guide.
    • ... and 25 other fixes and small changes.
  • 6.0.15
    • New Project Alert: A new Alert Popup (at bottom right) appears during the New Project Wizard when selecting a camera via a project (.pmr file) on the Camera Source pane. It displays the name of the camera that will be assigned to the photos in your project.
    • ... and 11 other fixes and small changes.
  • 6.0.14
    • 8 fixes and changes.
  • 6.0.13
    • 14 fixes and changes.
  • 6.0
    • There are numerous changes from Pro 5 to the first 6 version. Note the first public release was number 6.0.12 and includes all the beta changes listed in the log.

PhotoModeler Pro 5 Changes

  • Pro 5.2.3
    • Automarking Layers: In AutoMarking you can now select which layers all new marks will be added to.
    • New DDE Commands: SetPhotoSet, RemovePhotoSet, AddLayer, SetLayerByRegion, SetLayerByName, RemoveLayer, AutoReferenceByLayer, and DeleteMarkedPoint. See Help file for details.
    • Improved Precision Reporting: While this change is not a new feature we list it here to bring attention to it. There have been changes to the Total Error and Precision values. The Total Error is solved differently, the processing solution tolerance preference has changed, post-bundle precision values are solved differently, and post-bundle precisions now handle a project's coordinate system rotation properly. You may find your total error goes up with this release but the actual project quality has not gotten worse - PM just reports the error value differently.
    • Plus 34 other small changes and fixes.
  • Pro 5.2.2
    • Automated Calibration Parameterization: Camera Calibration has been improved in a number of ways. First, it automatically chooses the optimal set of camera parameters to solve with each camera. Second, it has new methods to improve robustness of calibrations for situations that would cause problems in the past (long focal length lenses for example).
    • Unreferenced Mark Highlight: All marks (points, edges, curves, cylinders, silhouettes) that have not yet been referenced to any other mark are displayed in a unique color so they can be readily identified.
    • Referencing Guide: PhotoModeler now highlights candidate point and silhouette marks in the desination photo during manual referencing. You can pick a mark that is not one of the candidates (or mark a new point) but generally one of the suggested marks is the correct one, thereby making manual Referencing easier.
    • Camera Station IDs: The ID number for Camera Stations can now be displayed in the 3D Viewer.
    • Silhouette Volume: The Measure Tool and the new Silhouette Table now display a silhouette's volume.
    • Silhouette Automatic Referencing: Silhouette marks can now be automatically referenced. Useful in applications where there are many organic shapes in a project.
    • Silhouette Mark Import: There is a new silhouette mark file import. Useful if you have an external process for automatically tracing silhouette outlines.
    • New DDE Commands and Improvements: The "Process", "AddCamera", and "RotateAxes" commands have been improved. The new commands are: "Translate", "CreatePointCloud", and "Show3DViewer".
  • Pro 5.2.1
    • Table Export Selected: You can now optionally export only the selected rows from a Table to a text file. See accompanying DDE change also.
    • Camera Station Scale/Rotate: Camera Station positions can now be used to set a project's scale and rotation.
    • Renumber: A new renumber function allows you to resequence the ID numbers for points, edges, cylinders, curves, photos, etc. If you have deleted photos or points and there are gaps in the numbering scheme, this function will remove those gaps.
    • End points in Tables: Curve, Edge and Cylinder Tables have new columns that show the X,Y,Z end points of these objects.
    • Improved Recalibrate Options: The Calibration Options have been further improved to provide more direct control over which camera parameters are solved.
    • New DDE commands: The DDE programming interface is improved with new commands. You can now programmatically request to export tables to text files (including only selected items - which gives a great capability to have a two way interaction between programs and user input). There are also changes to the Scale/Rotate DDE command (to add Camera Stations), and a change for the AddCamera DDE command to assign the camera to a specific photo.
    • Auto-Project Cleanup: There are a number of new functions for the automatic improvement and clean up of points in a Coded Target Auto-Project. These are: a) delete point marks remaining on just one photo, b) weld targets that are coded but mismarked, c) delete points that lie in a "disk" volume around a coded target, d) add a 2nd stage of autoreferencing, e) add a 3rd stage of processing and f) add an automatic point cloud surface to points named during autoreferencing.
  • Pro 5.2
    • Drag and Drop: You can now "drag and drop" files onto the PhotoModeler application window.
    • 4 or 5 Point Orientation: PhotoModeler will now automatically orient photos that have only 4 or 5 referenced marked points.
    • Full time marked point residual display: There is now an option to control Marked Point Residuals Display from the Photo Control Marked tab. ***Note: this replaces the Marking Residual Display Dialog.***
    • Full time sub-pixel target region display: There is now an option to control the visibility of Sub-pixel target marking regions from the Photo Control Marked tab.
    • 3D Viewer Region Select: Region select has been enhanced to work in the 3D viewer.
    • Maya Export: Added export of point data in a Maya .ma script format.
    • Enhanced PMV Tracking: A new type of tracking has been added to the PMV module.
    • New DDE Export command: Added new DDE command "Export" - Exports the currently loaded project in the format and with the options specified.
    • Apply Image Enhance: You can now apply the Image Enhance settings directly to the image file.
    • Show Highest Residual Command: A new tool has been added to the Point Table's right click popup menu which allows you to select and show the mark with the highest residual for a point.
    • New Calibration Options Dialog: When recalibrating it is no longer necessary to redo the entire calibration. There is now an option to perform or skip each major stage.
    • New Fast Automatic Segmentation setting for automarking: A new preference setting ("Use Fast Automatic Segmentation") has been added to the Target Marking tab of the Options dialog that when set to 'On' can dramatically increase circular target automarking in projects with very high contrast targets.
    • Precision Vector Length: The Precision Vector Length is now displayed in the Point Table.
    • Path Surface photo texture enhancement: Path Surfaces can now optionally grab their textures based on the mark's position in a photo as opposed to just the projected position.
    • New Reference Checker options: New settings on the processing dialog allow the choice of what the Reference Checker does during its second phase.
  • Pro 5.1.1
    • Reference Checker: The new, fully automated Reference Checker operates largely behind the scenes to review all point references before processing to detect possible errors. Once errors are detected the user is warned and the points are automatically pulled out of the processing. This can greatly increase the probability that all projects will process correctly the first time and is especially helpful with fully automated projects to improve accuracy, consistency and robustness.
    • Template Targets: Sub-pixel marking in PhotoModeler was only done with circular targets in the past but now corners, cross shapes, survey targets, edges, and user defined shapes can be used.
    • NCC PMV Tracking: Normalized Cross Correlation has been added as a option to PMV tracking. This method provides more robust tracking especially in images with noisy backgrounds or non-ideal targets.
    • 3D Viewer Axes Display: The 3D Viewer now optionally displays the X, Y, Z axes with control over size and placement.
    • Mouse Wheel Zoom: Photo Windows can now be rapidly zoomed in and out with the wheel on your mouse.
  • Pro 5.1
    • No new features - a couple of fixes - released to synchronize with the new CD pressing.
  • Pro 5.0.11
    • Auto-Project Constraints: The Coded Target Automatic Project now accepts the definition of distance constraints during setup. Good for high accuracy, fully automated target projects.
    • USB dongles: Support for USB dongles for locked versions (parallel port dongle support remains).
  • Pro 5.0.10
    • Filtered Zoom: There is a new option to smooth out zoomed-in images so they do not look pixelated. This can make some manual image marking easier to do and more precise.
    • LSM Residual Export: If you are a heavy user of sub-pixel marking you might want to study the quality of the LSM marking for each point. The LSM residuals, which can tell you how well the ideal circle target fit the image target, are now displayed and exported.
  • Pro 5.0.9
    • PMV and Coded Targets: The PMV Module now supports Coded Targets. Before tracking is started in each epoch, the coded target points will be detected and in the case of PMV type 2 projects can be used for the initial orientation of each epoch. Since these coded points are not 'tracked' in the traditional sense they can make sudden movements and even be tracked in and out of different epochs. This addition makes PMV Type 2 projects much more efficient and allows for interesting displacement vs time measurements.
    • Enhanced Project Wizard: the Automatic Project option in the New Project Wizard has been enhanced to include marking and automatic referencing of non-coded target points.
  • Pro 5.0.8
    • Fixes only.
  • Pro 5.0.7
    • Fixes only.
  • Pro 5.0.6
    • Enhanced PMV Module: There is a new "type 2" PMV project that can be used for displacement measurement. Type 2 projects are based on a single moving camera with some static non-moving points to define the reference frame across epochs.
    • New DDE Commands: A number of new commands have been added, making it easier to more fully automate PhotoModeler using external program control.
    • Improved Automarking: Automarking is now more efficient with a new "mark all photos" feature.
    • Cylinder Measure Improvements: You can now measure a cylinder's center line end point X,Y,Z positions.
    • Fully Automated Projects: Along with the Coded Target Module there is a new capability to fully automate the marking, referencing and processing of projects.
    • Improved Create Coded Targets Dialog: The updated dialog makes printing coded targets easier.
  • Pro 5.0.5
    • Fixes only.
  • Pro 5.0.4
    • User Customizable Short Cut Keys: A new dialog in the Options menu gives you the ability to assign your own keys to many of PhotoModeler's functions.
    • Scale and Translate: A new capability in the Scale and Rotate dialog allows you to scale and translate the coordinate system using camera station locations and distances.
    • K3 lens distortion: New support for this lens distortion parameter (for the sixth power of radial distance) in Camera Calibration allows wider angle lenses to be used more accurately.
  • Pro 5.0.3
    • Stereo View: A new option in the 3D Viewer Options dialog allows for an anaglyph-style stereo display in the 3D Viewer. This feature is useful for checking your results. It is also a fun feature - when used with the appropriate colored glasses, you can see the object in the 3D Viewer “pop” out of the screen.
    • Enhanced 3D Viewer Selection: The 3D Viewer now has a more powerful selection mechanism, particularly for objects close to each other in the 2D rendering.
    • Improved Projections: The Photo Projection system has been enhanced. Users can use the Preferences dialog to decide between speed or consistency for projected points and lines.
    • Enhanced Select Tool: When multiple items are selected, the Status Bar now displays the count of how many objects and their types.
  • Pro 5.0.2
    • Fixes only.

 

© 2013 Eos Systems Inc.